Spotipo v2 > v3 Upgrade Issue (Ubuntu 16.04)



  • Please see below:

    Traceback (most recent call last):
    File "/usr/share/nginx/spotipo/manage.py", line 30, in <module>
    app = create_app(mode='development')
    File "/usr/share/nginx/spotipo/unifispot/init.py", line 49, in create_app
    configure_extensions(app,user_datastore)
    File "/usr/share/nginx/spotipo/unifispot/ext/init.py", line 22, in configure_extensions
    configure_extension(configurator_name, app=app, db=db,user_datastore=user_datastore)
    File "/usr/share/nginx/spotipo/unifispot/ext/init.py", line 8, in configure_extension
    configurator = import_string(name)
    File "/usr/share/nginx/spotipo/.env/local/lib/python2.7/site-packages/werkzeug/utils.py", line 418, in import_string
    import(import_name)
    File "spotipo/unifispot/ext/routes.py", line 11, in <module>
    File "spotipo/unifispot/core/views.pyx", line 94, in init unifispot.core.views
    File "/usr/share/nginx/spotipo/.env/src/unifispot-menu/flask_menu/classy.py", line 99, in func_wrap
    expected = inspect.getargspec(f).args
    File "/usr/lib/python2.7/inspect.py", line 816, in getargspec
    raise TypeError('{!r} is not a Python function'.format(func))
    TypeError: <cyfunction AdminDashboard.index at 0x7f7da8f76050> is not a Python function
    dpkg: error processing package spotipo (--configure):
    subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
    spotipo
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    Spotipo is now broken and when trying to access the login page, I get "Bad Gateway".

    Please advise.



  • @Martyn-Boswell did you delete the old python environment?
    Try below commmand and install again

    sudo rm -rf /usr/share/nginx/spotipo/.env
    


  • @rakesh-mukundan said in Spotipo v2 > v3 Upgrade Issue (Ubuntu 16.04):

    rm -rf /usr/share/nginx/spotipo/.env

    No! I didn't know I had to, is this documented somewhere?



  • @Martyn-Boswell yes see the first step in upgrade documentation https://docs.spotipo.com/getting-started/upgrading-from-2



  • Doh! Apologies RTFM eh!

    Please delete this post if it's not useful to anyone.

    Thanks.


Log in to reply
 

});